
How To Make Your Own Kinemages
Kinemage-Construction Tutorial - Ricin
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Ricin is a complex toxin capable of crossing membranes and inactivating ribosomes by cleavage at a specific site 
in the RNA. It is composed of two unrelated polypeptide chains, with the catalytic site in the alpha/beta A chain, 
two similar antiparallel-beta domains in the B chain, and four bound carbohydrates. Its crystal structure was 
determined by Robertus and colleagues at the Univ. of Texas, and is PDB file 2AAI.

Kinemage 1 - a simple Calpha-backbone (to decorate later)

For an initial look at the ricin molecule, we will run a simple default Prekin script on file . Either 
drag-and-drop the 2AAI icon onto Prekin, or launch Prekin and open the file from its menu. The output file 
can be 2aai.kin. When the first dialog box of choices comes up, accept the default 'Backbone browsing 
script', which will execute a simple script producing Calphas, disulfides, and non-water het groups for all 
subunits in the file. When Prekin is done, it will launch Mage so you can look at the resulting kinemage.

2AAI.pdb

You should see Calpha backbones for the two ricin chains in different colors, with yellow disulfides and 
several bound sugars (pink). Move it around by dragging with the mouse. Such a simple, default kinemage 
shows many of the features of the structure, and is useful for many purposes. Note, however, that the 
viewpoint is arbitrary, the default colors and the names and arrangements of buttons are not ideal, and the 
sugar units are not connected to the protein. If you want to show particular details and get your point across 
to someone unfamiliar with the structure, then there are many ways to make the kinemage more informative 
and persuasive.

Choosing and saving views
First move around to find a view that spreads out the 3 domains in the plane of the screen, with the A chain 
(the white one) at the top. See if you can enlarge the zoom factor by one or two arrow-clicks without going 
off the screen edges. Type "s" on the keyboard to toggle into stereo, to make sure your zoom and orientation 



allow seeing most of the important parts in stereo (you can check for that, even if you can't see stereo 
yourself). Try improving the depth-cueing by clicking in the top half of the Zclip scroll-bar until something 
gets clipped away in the back or front, and then back off a step or two by clicking in the bottom half (a zclip 
of 130 or so will probably work well in this case). Recenter using 'pickcenter' if needed (or the "f" key to 
toggle to moving flat on the screen rather than rotating) and try using the keyboard keys "z" and "x" to move 
the center backward or forward, or "Z" and "X" for faster change. Once satisfied, choose 'Keep Current View' 
under the Edit menu, and save this as View 1, giving it a viewID such as "overview". Move the image, then 
choose View1 under the View menu, which should reproduce the view you just saved.

Turn on the 'Find' function under the Tools menu. In the dialog box, check that centering is on and ask for " 
177 ", which is the active-site Glu of ricin; Mage will center on Glu 177 and mark it. Zoom in somewhat, 
choose a view for the A chain that shows both the central beta sheet and the active-site Glu, and save it as 
View2, with a viewID of "A chain". Now pickcenter between the two domains of the B chain, zoom in, and 
save a view that shows the domains fairly equivalently, in a vertical orientation to allow for stereo. Locate the 
place where the chain moves between the two similar halves of the B chain, and make a note of that residue 
number (which you will use to put the two domains under the control of separate buttons).

Improving the colors and button names, and saving your modified kinemage
Turn on 'Change Color' on the Edit pulldown menu, then click on a sugar atom. Pull down the color-choice 
list and release on white, and Accept. Now you need to change the colors of the two subunits, A to differ 
from the white sugars and B to contrast better with the yellow SS bonds. The "tint" colors work well for 
Calpha backbones, because they can be distinguished without overwhelming small features you want to 
emphasize. Make the A chain yellowtint and the B chain greentint (try out some other possibilities, too).

Turn on 'Show Object Properties' under the Edit menu, and pick a sugar atom. The resulting dialog box will 
show you the program's internal data structure for this item. Edit the group name to "sugars". (Notice that it 
has the 'dominant' option below it checked, which hides its subgroup and list buttons on the button panel.) 
Accept the result, and see how the button has changed. Then edit the group names for the protein subunits, 
from '2AAI' to "Ricin A ch" and "B chain" (remember that you only get about 11 characters for a group button 
name, and 9 for a vectorlist name).

Choose 'Save as', under the File menu; you will be given a dialog box to locate and name the saved file, with 
a default name that ends in ".1.kin" rather than ".kin" (it won't let you re-use the original name). Quit out of 
Mage.

Making more pieces to add to the kinemage
The carbohydrates in ricin are "N-linked" - bound to Asn sidechain N atoms. In order to find and show those 
linkages, and produce other useful vectors for your kinemage, run Prekin on PDB file 2AAI again to produce 
2 different types of output: a) vectors for the active-site Glu 177 sidechain in the A chain b) all the Asn 
sidechains of the B chain To achieve this, do the following steps. Name the output file something like 
"2aai.xtra.kin". In the initial dialog box of Prekin, choose 'New Ranges'. In the range dialog specify residue 
177 to 177, check the 'sc' (sidechain) and 'at' (balls for non-C atoms) boxes, the 'OK accepts and ends ranges' 
box, and OK. In the following two dialogs, OK the defaults (no focus; 0.2 Å balls); in the last dialog check 
'only first subunit' and OK. When Prekin is done, choose 'New pass' (File menu); ask for 'New Ranges' again, 
replace the 3 dots by "asn" for '3-letter residue code', check 'sc', accept and end ranges, no focus, and this 
time edit the subunit range to 2, 2 and also check the 'subunits in range above' button. When done, launch 
Mage with the new kinemage. Then use "Append" on the File menu to read in your earlier ".1.kin" file as an 
add-on.

Using Drawline to draw sugar-Asn bonds, and Prune to delete unused Asn
Choose the B chain view and turn off everything but the Asn sidechains and the sugars. Turn on 'Draw New' 
on the Edit menu. For each of the two long (5-sugar) carbohydrate chains, find an Asn whose Nd2 atom is 
close enough to be covalently bonded (around 1.4 Å) to a sugar atom; use 'drawline' to add a line for the 
bond, by picking the two atoms. Select 'Draw New Setup' (Edit menu), and in the dialog box set 0.7 in the 
'shorten lines' box. Then, for each of the two-sugar chains, find an Asn whose Nd2 is H-bonded to a sugar 
atom (2.5-3 Å distance), and click on the two atoms to add a shortened line to represent the H-bond. (Turn 
off 'drawline' while measuring the distance, but if you accidentally draw an unwanted bond remove it with 



'eraselast'.)

Select 'Prune' on the Edit menu, which turns on 4 new buttons: 'punch' deletes single vectors or two that join 
at the point you picked; 'prune' deletes a connected string of P, L, L vectors; 'auger' removes things in a circle 
around the picked point; and 'undo p' will undo previous prunes in reverse order, up to about 10 steps back. 
Find an Asn far from any sugars, and try out these functions. Then remove all the unconnected Asn's, using 
two prunes at the Cgamma branch point for each one. Save the modified kin (this time Mage will suggest *
.2.kin). 

Using a word-processor to edit the kinemage file
Look at the file in your word-processor or other editor. First put the Glu 177 sidechain subgroup (balllist and 
vectorlist) after the Calphas of the A chain, with {Glu 177} as its master name. Edit its vectorlist color to 
something bright, contrasting, and oxygenish, such as pink or hotpink.

Under the B chain group, edit the subgroup name to "{domain 1}". Look up the residue number you 
identified as being the switch point between domains in the B chain, and divide the B chain Calphas into two 
vectorlists -- in order to do that, copy the subgroup and vectorlist lines and paste them in at the junction 
point; duplicate the switch-point Calpha, so it can be both the end of the domain 1 list and also the start of 
the domain 2 list. Edit the subgroup name to {domain 2} and the list color to bluetint. Put the correct 
vectorlist in each subgroup. Now paste in the Asn sidechains as two vectorlists, each under the correct 
subgroup (dividing them at the residue number you had determined). Edit the color to "sea" for the domain 1 
Asns (to go with the greentint Calphas) and "sky" for the domain 2 ones, to go with the bluetint. Delete the 
subgroup line before the SS sidechains, divide them into two vectorlists, and move the first one up into the 
domain 1 subgroup; edit the name of their masters to "{SS}".

At the end there should be a "New group" with the 4 bonds you drew between the Asn's and the sugars. 
Delete the group, subgroup, and list lines, which should leave those bonds suitably at the end of the sugar 
vectors. At the top of the file, delete the duplicated header information that belongs with the "xtra" material, 
making sure that you still have your views for chainA and chainB.

Save as a plain text file (Mage does its best to ignore formatting controls in word-processor files, but plain text 
is much safer). Look at the resulting kinemage to see if you did what you intended and whether you like the 
results. Modify views, and note anything that needs to be changed.

Write text and caption
In Mage again, set 'Text Editable' on the Edit menu. In the caption window, replace the default caption for 
Kinemage 1 with a short 2 or 3-line description of what is shown and what the colors mean. In the text 
window, put a title at the top in caps, your name(s) as author(s), then a blank line, "*{Kin 1}* Ricin A and B 
chain, with Glu 177, SS, and sugars", another blank line, and a paragraph or so about what a reader should 
look for in the kinemage. Leave in the PDB file name, at the bottom, but you may not want all the header 
information. Turn off "Text Editable" and save the file. The *{Kin 1}* is hypertext: clicking in it will take you to 
kinemage 1 (reinitialized); don't do this without saving first, or you'll lose your changes. The hypertext Table 
of Contents wil be very useful once you add more kinemages.

Before quitting, examine the kinemage again. If you were the reader, would you learn significantly more from 
this version than from the original default kinemage? This example was more complex than most, to introduce 
you to a variety of authoring tools. We hope it convinced you that worrying about how the kinemage looks is 
worthwhile, and that the process is fun.

Kinemage 2 - A Ribbon Schematic of both Ricin Chains
Prekin can make either a simple, default ribbon with no secondary-structure information, or else it can do 
arrows for beta ranges, spiral ribbons for helices, and widened single splines for coil. [To try out the first kind, 
choose 'Built-in scripts', 'Ribbon', and accept defaults. Note that the second kind of ribbon can also be done 
with explicit residue ranges specified in the Range dialog, as well as with a built-in script as you'll do here.] In 
order to do the more interesting ribbons for both chains of ricin, you will need to use an edited PDB file
called , with "sheet" records for chain B as well as chain A added to the header.2AAIed.pdb



Run Prekin built-in scripts, calling the output 2aaiRib.kin, and ask for Ribbon with helix/sheet records from 
PDB header. Accept the default ribbon controls; ask for all subunits.

Adding details, and changing ribbon colors
In a word-processor, look at the ribbon kinemage, which has vectorlists for the edges of strands, vectorlists 
with "width4" for the splines in coil, and ribbonlists for the beta strands (and for alpha, if there were any). At 
the top of the file, change '@kinemage 1" to "@kinemage 2". Give the group a name like {ricin A ch}. Just 
above that is a list of the masters; you can change the order of those lines in order to control the order of 
master buttons on the screen. Under the group, copy over the Gln 177 subgroup from your Kin. 1, to mark 
the active site.

Note the line that reads '@colorset= {beta2AAIeda} sea' -- this is a way to treat colors as variables, and lets you 
easily change the color of beta ribbons, which we will use to tell the chains apart. Search on "@group", or 
scroll down about halfway, to the beginning of chain B. Edit this beta colorset from sea to sky and change the 
group name to {ricin B ch}. Save as a plain text file.

Look at the kinemage, and save views for each chain. Make note of anything that needs fixing. Edit the text 
and caption to say something suitable. Save the kinemage again.

Kinemage 3 - Active Site, With Atom Balls and H-bonds
The Prekin 'Focus' option, and other active-site details
Run Prekin on file 2AAI again, with output file 2aaiA.kin. Choose 'Focus only'. In the next dialog box, choose 
to do the focus on a residue by number, and give the number 177 (for the active-site Glu). Try an 8 Å radius 
for sidechains, 12 Å for main chain, and 0 for everything else. Specify just subunit 1. When it is done, choose 
'New pass', and ask for ranges. Do an open range with just Calphas; OK and end; no focus; first subunit. 
When it finishes, launch the kinemage.

Pruning sidechains and main chain, and drawing H-bonds
Choose and save a view that gives a good closeup of the active site cleft. Turn off the Calphas. Prune away all 
the sidechains except for the two Glu, the two Tyr, the Arg, and the Trp. In 'Draw New Setup' set 'shorten 
lines' to 0.7, turn on 'Draw New', and draw in the sidechain H-bonds. There should be 3 H-bonds to main 
chain, from the Arg, Trp, and one Tyr. Now, prune away all main chain except for one peptide's worth (from 
Calpha to Calpha) at each of those 3 H-bonds. Use 'prune' to take out a residue at a time until you are close, 
then use 'punch' to trim down to the Calpha (this allows a smooth joining, later, between main chain and 
Calpha backbone).

Editing the backbone, and adding balls
Edit the kinemage you just saved, changing its number to 3. Delete the vectorlist line for the main chain 
('mc'). For each of the 3 mainchain peptides, cut-and-paste it between the correct Calphas. Delete the "new 
group" group line, rename its subgroup as {sc Hbonds} and add the parameter "dominant", and color its 
vectorlist purple. Rename the other groups, etc., so that they will make a good button layout. Do the 
sidechains as a dominant subgroup. Move the Glu 177 vectors to a separate list, so they can be colored pink. 
Between the sidechain subgroup and its vectorlist, add the following two lines (note that the word "balllist" 
really does have 3 l's):

Then COPY and paste all the sidechain oxygen atoms (from Glu and Tyr) under the first balllist and all the 
sidechain nitrogen atoms (from Arg and Trp) under the second one. This will produce a ball&stick 
representation for those parts. It is important to put the balls BEFORE their vectors, so that Mage can shorten 
those vectors appropriately to make the balls look like balls. [Note that Prekin can also generate non-C 
balllists directly, as you did in Kin.1.] Look at the resulting Kin. 3, and edit text and caption for it. Make a 
note of anything that needs to be fixed, and fix it.

@balllist {sc O} color= red radius= .2
@balllist {sc N} color= sky radius= .2

Kinemage 4 - Superimposing the Two Domains of Ricin Chain B
Chain B has two domains that each have the "beta trefoil" fold; superimposing them can show how similar 
they really are. We will use the beta strands, the disulfides, and especially 3 of the Trp sidechains as 



landmarks for doing the superposition in Mage with its docking function.

Using the 2AAI or the 2AAIed.pdb file as input to Prekin, name the output file something like 2AAIbsup.kin, 
and go to the Ranges dialog. Since the N-terminal tail is not equivalent and the domain changeover point is at 
about residue 138, specify numbers 7 to 138 for the range of domain 1 (top two entry lines), check "ca" 
(Calphas), and OK. Next time around leave 7-138, replace the "..." with "css" (to get the disulfides), uncheck 
"ca", check "sc" (sidechains), and OK. Then leave 7-138 and "sc", replace "..." with "trp", but this time check 
"OK accepts and ends ranges" before hitting OK. No focus. Check the "Do subunits in range above" radio 
button and specify subunits 2 to 2. When Prekin is done, choose "New Pass" from the File menu. In Ranges, 
do exactly the same 3 ranges as above, but for residues 138 to 9999 (to get domain 2), and again specify no 
focus and subunit 2. This time, launch the kinemage.

You should see all of chain B, with Trp sidechains in cyan and SS in yellow. Turn off the second button on 
the panel (domain 2) and use "Change color" (Edit menu) to make the domain 1 Calphas white. Drag with the 
mouse down and a bit left to get a view down the 3-fold axis of domain 1 - you should see 3 Trp sidechains 
as symmetrical "T" shapes, with a triangle of Calpha strands evenly behind a central opening. Type "x" 7 or 8 
times to bring the molecule forward. Save this view as View 1 with a name like "3-fold". There are 2 other Trp 
in domain 1 that are not symmetrically related around the 3-fold; use "Prune" to delete them. Turn on 
Domain 2 and make its Calphas some other color (maybe peachtint). Use "Show object properties" to give the 
two groups names like "B dom1" and "B dom2". Find the 3 symmetrical Trp in domain 2 and prune away the 
extra, fourth one.

The Dock3on3 Function
To define a docking scope so domain 2 can be moved onto domain 1, turn off domain 1 (leaving just domain 
2 showing) and choose "Docking scope" on the Tools menu. This will turn on a new set of sliders for moving 
the dockable object, but we'll use a shortcut method. Turn domain 1 back on and pick its 3 Trp to see their 
residue numbers. Turn on Draw New (Edit menu), and check the new "Dock3on3" button. Pick the 3 Trp 
Calphas in counterclockwise (sequence) order, starting with the one between the two SS; markers show, in 
red/green/blue order. Drag down and left (if you hit an atom, use eraselast) for a similar view of domain 2, 
and pick its 3 Trp Calphas also CCW starting between the SS. Domain 2 should jump on top of domain 1. 
Dock3on3 is not a root-mean-square function but superimposes the first point exactly, as you can now see. 
The other 2 Trp and the 2 SS all look offset in the same direction, so try this again. (Making a reasonable 
superposition is usually an iterative process.) Turn off domain 2 and pick CCW but starting with the 2nd Trp 
this time; then turn domain 2 on and 1 off, and pick the equivalent 3 Trp in the same order (you needn't 
worry about the markers, which are unpickable). With both domains on, this should show a good match. 
Which parts line up closely, and which parts differ? Turn off Docking scope.

Animating
Can you indeed see convincingly now that these two domains have the same fold? They are almost certainly 
related by a gene duplication. To set up animation between the two structures, use "Show object properties" 
to put a "*" at the very beginning of each of the two group names (make sure there isn't a space before the *). 
Then animate with the "a" key. Remember you can still turn on both at once. Save the kinemage.

Assembling a multi-part kinemage file
Paste the texts for Kins 2 and 3 into the text section of your original kinemage, adding Table-of-Contents 
hypertext entries, plus some text for Kin 4. Paste first Kin 2, then Kin 3, then Kin 4 (changing its kinemage 
number) onto the end of your previous file (for each, start with "@kinemage n" and go to the end).

You have now made a quite complicated kinemage file, which illustrates a number of interesting things about 
ricin. Congratulations!


